OnDemand

The OnDemand interface allows you to conduct your research on Bridges through a web browser.   You can manage files - create, edit and move them - submit and track jobs, see job output, check the status of the queues, run a Jupyter notebook through JupyterHub and more, without logging in to Bridges via traditional interfaces.

OnDemand was created by the Ohio Supercomputer Center (OSC).  This document provides an outline of how to use OnDemand on Bridges. For more help, check the extensive documentation for OnDemand created by OSC, including many video tutorials, or email bridges@psc.edu. 

This document covers these topics:

Start OnDemand

To connect to Bridges via OnDemand, point your browser to https://ondemand.bridges.psc.edu.

  • You will be prompted for a username and password.  Enter your PSC username and password.
  • The OnDemand Dashboard will open.  From this page, you can use the menus across the top of the page to manage files and submit jobs to Bridges.

To end your OnDemand session, choose Log Out at the top right of the Dashboard window and close your browser.

 

Manage files

To create, edit or move files, click on the Files menu from the Dashboard window.  A dropdown menu will appear, listing all your file spaces on Bridges: your home directory and the pylon directories for each of your Bridges' grants. 

Choosing one of the file spaces opens the File Explorer in a new browser tab.  The files in the selected directory are listed.  No matter which directory you are in, your home directory is displayed in a panel on the left.

There are two sets of buttons in the File Explorer.

Buttons on the top left just below the name of the current directory allow you to ViewEdit, Rename, Download, Copy or Paste (after you have moved to a different directory) a file, or you can toggle the file selection with (Un)Select All.

Buttons on the top of the window on the right perform these functions:

Go To Navigate to another directory or file system
Open in Terminal Open a terminal window on Bridges in a new browser tab
New File Creates a new empty file
New Dir Create a new subdirectory
Upload Copies a file from your local machine to Bridges
Show Dotfiles Toggles the display of dotfiles
Show Owner/Mode Toggles the display of owner and permisson settings

 

Create and edit jobs

 You can create new job scripts and edit existing scripts, and submit those scripts to Bridges through OnDemand.

From the top menus in the Dashboard window, choose Jobs > Job Composer.  A Job Composer window will open.

There are two tabs at the top: Jobs and Templates.

In the Jobs tab, a listing of your jobs is gven. 

Create a new job script

To create a new job script:

  1. Select a template to begin with
  2. Edit the job script
  3. Edit the job options 

Select a template

  1. Go to the Jobs tab in the Jobs Composer window. You have been given a default template, named Simple Sequential Job.
  2. To create a new job script,  click the blue New Job > From Default Template button in the upper left. You will see a green message at the top of the window, "Job was successfully created".

At the right of the Jobs window, you will see the Job Details, including the location of the script and the script name (by default, main_job.sh).  Under that, you will see the contents of the job script in a section titled Submit Script.

Edit the job script

Edit the job script so that it has the commands and workflow that you need.

If you do not want the default settings for a job, you must include options to change them in the job script.  For example, you may need more time or more than one node.  For the GPU partitions, you must specify the type and number of GPUs you want.  For the LM partition, you must specify how much memory you need.  Use an SBATCH directive in the job script to set these options.

You can edit the script in several ways.

  • Click the blue Edit Files button at the top of the Jobs tab in the Jobs Composer window
  • In the Jobs tab in the Jobs Composer window, find the Submit Script section at the bottom right.  Click the blue Open Editor button.

After you save the file, the editor window remains open, but if you return to the Jobs Composer window, you will see that the content of  your script has changed.

Edit the job options

In the Jobs tab in the Jobs Composer window, click the blue Job Options button.  The options for the selected job such as name, the job script to run, and the account it run under are displayed and can be edited.  Click Save or Cancel to return to the job listing.

 

Submit jobs to Bridges

Select a job in the Jobs tab in the Jobs Composer window. Click the green Submit button to submit the selected job.  A message at the top of the window shows whether the job submission was successful or not.  If it is not, you can edit the job script or options and resubmit.  When the job submits successfully, the status of the job in the Jobs Composer window will change to Queued or Running.  When  the job completes, the status will change to Completed.

 

JupyterHub and IJulia

You can run JupyterHub, and IJulia notebooks, through OnDemand.  You must do some setup before the first time you run IJulia through OnDemand.

Setup IJulia for OnDemand use

You only need to do this once.

While logged in to Bridges, request an interactive session with access to sites external to Bridges by typing:

interact --egress

Once the sesstion starts, type these commands:

module load anaconda3
module load julia
julia

When Julia starts, type

Pkg.add("IJulia")

 When you see the message that IJulia has been installed, you can end your interactive session.

  1. Select Interactive Apps >> Jupyter Notebooks from the top menu in the Dashboard window. 
  2. In the screen that opens, specify the timelimit, number of nodes, and partition to use. If you have more than one grant on Bridges, you can also designate the account to deduct this usage from .

    If you will use the LM or one of the GPU partitions, you must add a flag in the Extra Args field for the amount of memory or the number and type of GPUs you want:

    --mem=numberGB

    --gres=gpu:type:number 

    See the Running jobs section of this User Guide for more information on Bridges' partitions and the options available.

  3. Click the blue Launch button to start your JupyterHub session.  You may have to wait in the queue for resources to be available.
  4. When your session starts, click the blue Connect to Jupyter button.  The Dashboard window now displays information about your JupyterHub session including which node it is running on, when it began, and how much time remains.

    A new window running JupyterHub also opens.  Note the three tabs: Files, Running and Clusters.

    Files

    By default you are in the Files tab, and it displays the contents of your Bridges home directory.  You can navigate through your home directory tree.   

    Running

    Under the Running tab, you will see listed any notebooks or terminal sessions that you are currently running.

  5. Now you can start a Jupyter or IJulia notebook:
    1. To start a Jupyter notebook which is stored in your home directory space, in the Files tab, click on its name.  A new window running the notebook opens.
    2. To start a Jupyter notebook which is stored in your pylon5 directory, you must first create a symbolic link to it from your home directory. While in your home directory, use a command like
      ln -s /pylon5/yourgroup/youruserid PYLONDIR

      When you enter JuypterHub, you will see the entry PYLONDIR in your list of files under the Files tab. Click on this to be moved to your pylon5 directory.

    3. To start IJulia, in the Files tab, click on the New button at the top right of the file listing. Choose IJulia from the drop down.

 

Errors

If you get an "Internal Server Error" when starting a JupyterHub session, you may be over your home directory quota. Check the Details section of the error for a line like:

#<ActionView::Template::Error: Disk quota exceeded @ dir_s_mkdir - /home/joeuser/ondemand/data/sys/dashboard/batch_connect/sys/jupyter_app...............

You can confirm that you are over quota by opening a Bridges shell access window and typing 

du -sh

This command shows the amount of storage in your home directory.  Home directory quotas are 10GB. If du -sh shows you are near 10GB, you should delete or move some files out of your home directory.  You can do this in OnDemand in the File Explorer window or in a shell access window.  

When you are under quota, you can try starting a JupyterHub session again.

 

Stopping your JupyterHub session

In the Dashboard window, click the red Delete button. 

 

RStudio

You can run RStudio through OnDemand. 

  1. Select Interactive Apps > RStudio Server from the top menu in the Dashboard window.
  2. In the screen that opens, specify the timelimit, number of nodes, and partition to use.  You can also designate the account to apply this usage to if you have more than one grant on Bridges.

    If you will use the LM or one of the GPU partitions, you must add a flag in the Extra Args field for the amount of memory or the number and type of GPUs you want:

    --mem=numberGB

    --gres=gpu:type:number 

    See the Running jobs section of this User Guide for more information on Bridges' partitions and the options available.

  3. Click the blue Launch button to start your RStudio session.  You may have to wait in the queue for resources to be available.
  4.  When your session starts, click the blue Connect to RStudio Server button.  A new window opens with the RStudio interface.  

Errors

If you exceed the timelimit you requested when setting up your RStudio session, you will see this error:

Error: Status code 503 returned

To continue using RStudio, go to Interactive Apps > RStudio from the top menu in the Dashboard window and start a new session.

 

Stopping your RStudio session

To end your RStudio session, either select File > Quit Session or click the red icon in the upper right of your RStudio window.  NOTE that this only closes your RStudio session; it does not close your interactive Bridges session. You are still accruing Service Units.  If you like, you can start another RStudio session.

To end your interactive Bridges session so that you are no longer accruing Service Units, return to the Dashboard window and click the red Delete button. 

 

Shell access

You can get shell access to Bridges by choosing Clusters > >_Bridges Shell Access from the top menus in the Dashboard window.  In the window that opens, you are logged in to one of Bridges' login nodes as if you used ssh to connect to Bridges.  

 

Miscellaneous

Accessing Bridges documentation

In the Dashboard window, under the Help menu, choose Online Documentation to be taken to the Bridges User Guide.

 

Change your PSC password

In the Dashboard window, under the Help menu, choose Change HPC Password to be taken to the PSC password change utility.

 

System Status

  • Bridges status

     

     Upcoming maintenance Oct. 22-26

    The /pghbio filesystem will be down Oct. 22-26. Bridges, Olympus, all VMs & filesystems down Oct. 24-26. Read more

New on Bridges

The default version of Singularity is now 3.0.0.
Read more

The GPU limit per job is now set to 8.
Read more

Omni-Path User Group

The Intel Omni-Path Architecture User Group is open to all interested users of Intel's Omni-Path technology.

More information on OPUG